The issue affecting customer screening has now been resolved.
Screening is now processing as expected, and all previously impacted customers are now active.
New customer accounts will continue to be screened and made live automatically following creation.
We apologise for the inconvenience caused.
Posted Jun 02, 2026 - 09:46 BST
Monitoring
We have identified the issue affecting customer creation, which is related to the screening of accounts not functioning as expected.
Customer creation is currently processing successfully; however, you still may not be able to create new accounts.
Once the issue is resolved, we will automatically complete the screening process and activate all affected customers.
No action is required from you at this time. We will continue to provide updates as progress is made. We apologise for the inconvenience caused. If you require any further support, please contact us at support@modulrfinance.com.
Posted Jun 02, 2026 - 09:43 BST
Investigating
Since 08:35 today, we have been experiencing an issue affecting new customer onboarding. Customer records are being created successfully; however, customers are placed into a “blocked” status, preventing associated account creation.
Our team is actively investigating the root cause and treating this as a priority. Customer creation requests are being processed, but accounts cannot be created while customers remain in this state.
We are working as quickly as possible to resolve this and will provide a further update shortly. We sincerely apologise for the disruption caused and understand the impact this may have. If you require further support, please contact support@modulrfinance.com.