Twilio Authy Authentication Service Disruption

Incident Report for Modulr Finance Limited

Resolved

Thank you for your patience. We're pleased to confirm that the issue has been resolved and the Twilio Authy app is now fully operational. We apologise for any inconvenience this may have caused.

If you're still experiencing any login difficulties, please don’t hesitate to contact us at support@modulrfinance.com.
Posted Oct 21, 2025 - 09:08 BST

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 18:30 BST

Identified

We are currently experiencing issues with the Twilio Authy authentication app, which is impacting our login verification process.
This disruption is due to a server issue with one of our third-party providers. We are actively working with them to investigate and resolve the problem as a top priority.

We will provide updates as soon as more information becomes available and notify you once the issue has been fully resolved.

Thank you for your patience and understanding.

For any urgent enquires, please reach out to support@modulrfinance.com.
Posted Oct 20, 2025 - 18:30 BST
This incident affected: Twilio Authy App and Twilio Authy 2FA.